unfortunately android keyboard has stopped FIX

unfortunately android keyboard has stopped

unfortunately android keyboard has stopped error in Google Android CyanogenMod CM10.1 custom rom is a very simple issue to fix.

  • Goto your phone settings -> Apps
  • Change from “Downloaded” tab to “All” tab.
  • Click on “Android keyboard (ASOP) and click on “Clear Data”.
  • Click on “Dictionary Provider” and click on “Clear Data”.

unfortunately android keyboard has stopped FIX

67 thoughts on “unfortunately android keyboard has stopped FIX

  1. Janice

    Thanks! Don’t really care for the new keyboard that popped up but I am grateful I can finally use one. Life saver… this was really about to ruin my day lol. Seriously.

    1. shauna

      It worked!!!! I love this posting. It was driving me freaking crazy…i was told i may have to buy a new phone…NOT!!!!

    2. Flesh

      Me too, thanks man.. I dont care much for it either, but all ii have is txtng right now so idv been majorly screwd!

  2. eddy

    I’ve been disturbed by the message when trying to manipulate my HTC phone, and I’m getting this message: Unfortunately, Android keyboard(AOSP) has stopped

    1. Thembisile

      How am having this problem but I did all that but still it show unfortunately, Google keyboard has stopped plz am using Fondi tables Android 4.4 plz help

  3. arvinan

    i have been using Pacman rom, for last 5 months, this issue appeared yesterday, done all above mentioned, nothing did work. DL anthoer rom Resurrection Remix v4.0.6, full wipe,same issue, tried with again did a full wipeChameleon-xwlss-3.0.2 IFIXED. problem solved for me. i think difrrent kernel solved the issue.

  4. Richard Smith

    Just updated galaxy note 8 to 4.2. At startup it asks for info that requires input from the keyboard. But says “unfortunately android keyboard has stopped working” .can’t continue. Had to flash back to 4.1 any ideas

  5. arvinan

    Hi Richard

    I don’t think you can roll back in a stock android sytem.
    Research on how to root your device, then install a custom rom. Costom roms are light years head of bloated stock roms.
    A good start will be in xda dev. forum.

    Good luck

  6. Dennis

    I actually did all this stuff and no i got no results… I still need help with this. I have cynaogenmod 9!

    1. Cat

      Dear Arvinan,
      Most people on this forum are just average phone/ tablet owners looking to save themselves from having to replace a device that has glitched, as opposed to computer programmers of any sort. So, since your links are disabled, on behalf of these people and myself for whom the simple fix above did not work, I will ask you a few questions of clarification to better understand your advice.
      1. What is gapps?
      2. What would constitute its equivalent and how might we judge the appropriate choice for our device? (Mine, for instance is a Motorola Xoom, so perhaps it is difficult to find as it is dated?)
      3. How might this gapps version be installed?
      4. What is CM an abbreviation of?
      5. What is a “vers” and where might it be located?
      6. What is a “wipe” and how is it “done”?
      7. What is “rom” and how might that be installed?

      Best Regards,

  7. amber

    i tried and it still not working, i keep getting the message “Unfortunately, android keyboard has stopped”

  8. Thamson Antony

    Thank you sooooooooooooooooooo muchhhhhhhhhhhhhh!!! i was freaking out when i got this problem!! God Bless!!

  9. Manohar

    Hello Guys,

    I’ve installed the ROM – JellyTime 4.3 Beta 6

    I have cleared the data for the app Android keyboard (AOSP)

    But, I don’t see the app Dictionary Provider on the All Apps page, rather I see “User Dictionary”. But, ‘Clear Data’ button is disabled for this App. I clicked on ‘Force Stop’. But, nothing changed. The phone is showing same pop-up “Unfortunately, Android keyboard (AOSP) has stopped on Android “…

    Please help me in resolving this issue.


  10. Zulu

    It really worked thank you very much. I was frustrated by the message that continuously popping up.

  11. Savvy D

    Thanks Boss. The “Clear Data” option did not work, but when I “disabled the Dictionary Provider” all went well.
    My month long nightmare is finally over.

    1. JOEY Pats

      That just worked for me as well. I’m running the newest stable version of Cyanogen on a Barnes & Noble Nook HD.

  12. Jack H.

    Thanks! This helped me resolve this issue with a Nexus S 4g (crespo4g) with a CM11 Nightly build that I recently installed the Android Lollipop keyboard onto. THANK YOU AGAIN.

  13. crystal

    Works! Works! Works! This was stressing my Night out. I can finally finish texting people get to bed. Sometimes a random website will have no idea the impact they had on soimeone. You literally saved me . Thank for your advice 🙂

  14. jullie

    Thanks so much..ma life is much easier now..it took me all day without chatting.at first it wasn’t working until I disabled dictionary provider

  15. Earline

    Thanks so much!! At first it didn’t work but I enabled all disabled apps and bam it’s all good now…..was going crazy not being able to text folks back…..Thanks again!!

  16. Kirankumar

    Thank you very much i was screwed a lot for a while your post helped me to fix this is issue

  17. crystie

    Use the age old Indian method to fix this problem. After following the above steps, just switch off your mobile, take out its battery and sim cards. Clean these parts gently using soft clothes and blowing air from mouth for difficult regions. Rearrange the whole thing again after cleaning and the switch on your mobile.. mine was saved by this today only… working perfectly now

  18. Christopher

    Took it to Verizon, the guy pressed the power and the down volume until the phone powered off and came back on. He said the error was resolved so I left. When the phone powered up the keyboard error was still there. I found this site and went to the apps as instructed. My phone app says -Google keyboard-. I cleared the data and cache and the error went away. I have the droid Htc phone so my setting were a little different but the end result was great. Thanks for steering me in the right direction.

  19. pruthvirajsinh vara

    I am not able to type the cheats in xolo black during game. The keyboard pop ups but not able to type pls help me

  20. Steve

    I had the same problem, could not connect to the internet, because I had no keyboard. I searched “ai keyboard apk” , they have a free one. I downloaded it on my laptop and then transferred it to my phone using a USB cable, then I ran it from the phone, installed great, I disabled the android keyboard aosp and now I have a perfect working phone, using the ai keyboard. I hope this helps, I tried all the above ideas, but they did not work for me, of coarse pretty much any keyboard apk will work.

  21. Dell

    I had same problem also back button not working after I update my Xperia Miro to Kitkat.
    I solved it with ICS Keyboard.apk at 4shared. I downloaded it on my laptop and then transfer it to my phone using a USB cable. Then I installed it from the phone. I also disable Android Keyboard in the application settings. ITS WORKING!!!
    Finally, I got back and at the same time its helps my back button working. I am very grateful and very happy. Hope this helps.

  22. lewie

    Only worked for one day for me, so I went to Play Store and did a voice search for ‘Keyboard’ and chose Keyboard Red and that worked for me.
    Google warned that it could be a keylogger, but many like it and I only use this phone for games and GPT sites anyway, so I wouldn’t care.

  23. 86Claudette

    I have noticed you don’t monetize your website, don’t
    waste your traffic, you can earn additional cash every month because you’ve got hi quality content.
    If you want to know how to make extra money, search for: best adsense alternative Wrastain’s tools

  24. Liliana

    Hello there,

    I have the same problem except I dont have the “clear data” option to click.

    Any help is more than welcome, thanks in advance 😀

  25. Dennis Walters

    Wow, excellent post… This is really a great article and a great read for me. It’s my first visit to your blog and I have found it so useful and informative specially this article.
    Thank you so much…


Leave a Reply

Your email address will not be published. Required fields are marked *


This site uses Akismet to reduce spam. Learn how your comment data is processed.